Fehlermeldung http/https

 
Thorsten77
Benutzer
Avatar
Geschlecht:
Herkunft: Lauffen a.N.
Homepage: bahnrelikte.de
Beiträge: 14
Dabei seit: 08 / 2022
Betreff:

Fehlermeldung http/https

 · 
Gepostet: 23.08.2022 - 22:00 Uhr  ·  #1
Wahrscheinlich nur ein kleiner Fehler in der Konfiguration

Ich erhalte diese Fehlermeldung

Zitat

Bad Request
Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.


Das Passiert immer, wenn ich länger nicht am Rechner sitze.
Oben in der Menüleiste ist das Login-Symbol aufgetaucht (anscheinend wurde ich automatisch ausgeloggt)
Klicke ich da drauf werde ich zu Login-Formular weitergeleitet.
Nach der Eingabe der Login-Daten und auf Einloggen erscheint dann die o.g. Fehlermeldung.

Im Browser-Adressfeld (Chrome) steht diese URL
Code
http://xyz.de:443/acp/login.php


lösche ich alles hinter dem ".de" und drücke Enter lande ich komischerweise eingeloggt auf der Startseite
minerali
Benutzer
Avatar
Geschlecht:
Herkunft: Deutschland
Alter: 71
Homepage: gedichte-stuebchen…
Beiträge: 191
Dabei seit: 07 / 2020
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 23.08.2022 - 22:24 Uhr  ·  #2
Hallo Thorsten,
hast Du in Deinem Hosting auch ein SSL Zertifikat hinterlegt (z.B. letsencrypt). Vermutlich ist in der Forenkonfiguration Port 443 für SSL/https aktiviert. Wenn Du kein gültiges Zertifikat auf Deinem Hosting hast, dann entweder eines einsetzen oder in der Config auf Port 80/http umstellen. Eigentlich erkennt die Software das von selbst, ob https oder http. Bisher hatte ich damit noch keine Probleme. Versuche mal einen anderen Browser wie FireFox, vielleicht ist der freundlicher zu Dir.
Grüße von Brigitte
Thorsten77
Benutzer
Avatar
Geschlecht:
Herkunft: Lauffen a.N.
Homepage: bahnrelikte.de
Beiträge: 14
Dabei seit: 08 / 2022
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 23.08.2022 - 22:43 Uhr  ·  #3
Rufe ich direkt die url auf, also ohne etwas hinter dem *.de wird ein Schloss oben eingeblendet.

Habe mal die Cookies und alle Temps vom Forum entsorgt. Mal abwarten, was passiert.
minerali
Benutzer
Avatar
Geschlecht:
Herkunft: Deutschland
Alter: 71
Homepage: gedichte-stuebchen…
Beiträge: 191
Dabei seit: 07 / 2020
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 23.08.2022 - 22:56 Uhr  ·  #4
Thorsten77
Benutzer
Avatar
Geschlecht:
Herkunft: Lauffen a.N.
Homepage: bahnrelikte.de
Beiträge: 14
Dabei seit: 08 / 2022
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 26.08.2022 - 00:13 Uhr  ·  #5
So scheint zu klappen.

Im ACP habe ich
  • Verschlüsselte Cookies aktiviert
  • unter "Wartung" alle Caches geleert


Auf dem Rechner im Browser den Cache geleert, und alle Cookies gelöscht

Bei Strato das "PHP-Boost" deaktiviert (ist jetzt wieder aktiv) und HTTPS erzwungen

Und mich danach wieder eingeloggt (Cookies akzeptiert)

Was es schlußendlich war, kann ich nicht sagen
minerali
Benutzer
Avatar
Geschlecht:
Herkunft: Deutschland
Alter: 71
Homepage: gedichte-stuebchen…
Beiträge: 191
Dabei seit: 07 / 2020
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 26.08.2022 - 17:48 Uhr  ·  #6
Hi Thorsten,
da war vorhin noch ein Post von Chris mit dem Hinweis auf ACP/Sicherheit/https Assistent. Hier sollte, bis auf die ersten Beiden, überall ein Haken drin sein. Falls nicht, wird auch angezeigt, was für ein Problem vorliegt. Das nur noch mal, falls es unerwartet wieder nicht geht.

Anscheinend hat Chris den Post selbst gelöscht, obwohl ich den Hinweis recht wertvoll fand.

Weiterhin gutes Gelingen und schönes Wochenende.
Grüße von Brigitte
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.net
Beiträge: 17565
Dabei seit: 12 / 2003
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 26.08.2022 - 18:53 Uhr  ·  #7
Hallo in die Runde,

ja, ich hatte den Hinweis wieder herausgenommen, da sich Thorstens Problem ja offenbar schon gelöst hatte. Frei nach dem Motto: Am funktionierenden System dann besser nichts mehr umstellen, damit nicht doch wieder was kaputtgeht. ;)

Trotzdem ist der HTTPS Assistent im ACP unter "Sicherheit" ein hilfreiches Tool, die Konfiguration des Forums für https Umgebungen zu überprüfen, und wurde dafür ja entwickelt, um hier eine Erleichterung zu bieten.

Dort können schon auch ruhig alle Häkchen grün sein, dann hat man wirklich für jede Situation und Möglichkeit die passende Einstellung. In diesem Fall war es vermutlich wie von Brigitte vermutet die allgemeine Foren-Domain, die noch auf http statt https war, und der Port, der vermutlich noch auf 80 statt 443 war. Der https Assistent spürt solche Probleme dann allerdings automatisch auf und hilft bei der Konfigurationsanpassung.

Auch bietet es sich an, ganz oben in diesem Panel den integrierten / automatischen Bildproxy zu aktivieren. So werden auch von Usern per BBCode eingebundene (unverschlüsselte) Bilder verschlüsselt übertragen und man vermeidet so eventuelle "Mixed Content" Warnungen. Außerdem bietet dies zusätzlich mehr Datenschutz für die User, da externe Server mit eingebetteten Bildern nicht mehr von der IP Adresse der Forennutzer kontaktiert werden, sondern der Bildproxy das erledigt und weitergibt.

Viele Grüße und ein schönes Wochenende,
Chris
minerali
Benutzer
Avatar
Geschlecht:
Herkunft: Deutschland
Alter: 71
Homepage: gedichte-stuebchen…
Beiträge: 191
Dabei seit: 07 / 2020
Betreff:

Re: Fehlermeldung http/https

 · 
Gepostet: 26.08.2022 - 21:02 Uhr  ·  #8
Hallo aus der Runde an Chris,

Zitat
Dort können schon auch ruhig alle Häkchen grün sein, dann hat man wirklich für jede Situation und Möglichkeit die passende Einstellung. In diesem Fall war es vermutlich wie von Brigitte vermutet die allgemeine Foren-Domain, die noch auf http statt https war, und der Port, der vermutlich noch auf 80 statt 443 war. Der https Assistent spürt solche Probleme dann allerdings automatisch auf und hilft bei der Konfigurationsanpassung.

Schon richtig, wollte Thorsten nur nicht verwirren, da auf seinem Forum noch nichts drauf ist und die ersten 2 Bereiche den Fehler wohl nicht verursacht hätten.

Danke, dass Du noch mal alles ausführlich dargelegt hast.

Dir auch ein schönes Wochenende.

Grüße von Brigitte
Gewählte Zitate für Mehrfachzitierung:   0

Registrierte in diesem Topic

Aktuell kein registrierter in diesem Bereich

Die Statistik zeigt, wer in den letzten 5 Minuten online war. Erneuerung alle 90 Sekunden.