CBACK Welcome Post Konfiguration

 
badMoon
Benutzer
Avatar
Geschlecht:
Herkunft: Nettetal / NRW
Alter: 68
Homepage: musikzirkus.eu
Beiträge: 209
Dabei seit: 02 / 2013
Betreff:

CBACK Welcome Post Konfiguration

 · 
Gepostet: 27.09.2022 - 14:20 Uhr  ·  #1
...da isser wieder ;-)

Hallo Chris,

unsere neu angemeldeten Mitglieder sollen den Welcome-Post mit Link zur Vorstellungsseite erhalten. Unsere Konfiguration füge ich als Hardcopy bei. Der rot markierte Link ist korrekt, dort befindet sich der Vorstellungsbereich.

Leider jedoch erhält das neue Mitglied trotz korrekter Berechtigungsvergabe beim Klick auf den Link die Fehlermeldung "keine Lesebefugnis".

Testweise habe ich mich neu angemeldet. Tatsächlich funktioniert der Link nicht. Gehe ich jedoch über unsere Portalseite auf die dort fest verdrahtete Verlinkung, komme ich in den Vorstellungsbereich und kann dort schreiben.

Hast Du einen Tipp?

Danke und Gruß,
Wolfgang
Der an diesem Beitrag angefügte Anhang ist entweder nur im eingeloggten Zustand sichtbar oder die Berechtigung Deiner Benutzergruppe ist nicht ausreichend.
minerali
Benutzer
Avatar
Geschlecht:
Herkunft: Deutschland
Alter: 71
Homepage: gedichte-stuebchen…
Beiträge: 191
Dabei seit: 07 / 2020
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 27.09.2022 - 18:36 Uhr  ·  #2
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.net
Beiträge: 17565
Dabei seit: 12 / 2003
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 27.09.2022 - 19:28 Uhr  ·  #3
Hi Wolfgang,

Deine Webseite ist sowohl mit als auch ohne www. erreichbar:

https://musikzirkus.eu/forum/xt.php?app=portal
https://www.musikzirkus.eu/forum/xt.php?app=portal


Ich vermute also, dass der User sich über "die andere" Variante eingeloggt hatte (in dem Fall wohl die mit www., weil Dein Link ohne ist) und deshalb in eben dieser Variante noch ausgeloggt war, da die Cookies im Browser es mit den Subdomains auch bei gleicher Seite dahinter sehr genau nehmen.

Ich würde der Empfehlung vom Handbuch folgen, dass Du Dich für die in Deiner Foren-Konfiguration gesetzte Variante (entweder mit oder ohne www.) entscheidest und via .htaccess die andere Variante umleitest. Soweit ich anhand der automatischen Portalweiterleitung beim Direktaufruf entnehme wäre Deine Standardvariante ohne www.

Beispiel:

Du rufst
Code
https://www.community.cback.net/cback-welcome-post-konfiguration-t18150.html


auf und landest automatisch auf

Code
https://community.cback.net/cback-welcome-post-konfiguration-t18150.html


weil Du umgeleitet wirst auf die in der Konfiguration eingestellte Hauptadresse (ohne www).

Das erspart Dir auch in vielen anderen Forenbereichen mit Weiterleitung solche eingeloggt / ausgeloggt Problematiken.
In den Supportbereichen findest Du da auch einige Konfigurationstipps zu (z.B. hier oder hier) und die Standard .htaccess hat auch schon einen Konfigurationsvorschlag für eine automatische Umleitung, den Du einfach anpassen und aktivieren kannst. Näheres dazu auch im Anwenderhandbuch Seite 30 zur Konfiguration. :)

Mit dem Plugin hat das also nichts zu tun.

Wenn es auch dann nicht geht, stimmt ein zugewiesenes Leserecht für die Nutzergruppe eines neu registrierten Users noch nicht in Deinen Foren-Berechtigungseinstellungen oder für die Kategorie, welcher das Forum angehört. Dann also CF4 Befugniseinstellung nicht vollständig und damit auch nicht das Plugin das Problem. Denke dran, dass Du mit Deinem Admin-Account mehr Rechte hast als ein normaler User zum Testen, Du musst in der Befugnis-Matrix also sicherstellen, dass die entsprechende Gruppe für neu registrierte das entsprechende Leserecht bei Kategorie + Forum auch korrekt gesetzt hat (sprich: Gruppenfarbe in der Befugnismatrix sichtbar beim entsprechenden Rechtepunkt). Das würde dann analog zu diesem Tipp funktionieren, den ich Dir mal bei den Befugnissen gegeben habe: bilder-upload-wer-darf-die-bil…real163725 - in dem Fall nur für "Forum sehen" und "Thema lesen" (das sind 2 trennbare Punkte, müssen dann zum Lesen des Foreninhaltes und sehen des Forums auf dem Index also beide für die jeweilige Gruppe aktiviert sein).

LG,
Chris
badMoon
Benutzer
Avatar
Geschlecht:
Herkunft: Nettetal / NRW
Alter: 68
Homepage: musikzirkus.eu
Beiträge: 209
Dabei seit: 02 / 2013
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 28.09.2022 - 11:48 Uhr  ·  #4
@Brigitte,

...auch wenn dies nicht der richtige Weg war - vielen Dank für Deine Antwort und Dein Hilfsangebot :-)

@Chris,

besten Dank für Deine wie immer umfangreiche und hilfreiche Antwort. Noch eine kurze Nachfrage:

M.M.n. wäre in der htaccess keine Anpassung erforderlich, da der Link zum Vorstellungsthread auch ohne "www" angegeben wurde. Ist das richtig?

Bzgl. der Berechtigung sind die Einstellungen korrekt. Ich habe mich als neuen User angemeldet, komme in alle für Newbies freigegebenen Bereiche. Nur eben - Mit der Aufforderungsbitte zur Vorstellung wird besagter Fehler angezeigt.

Ich hänge Hardcopies unserer Foreneinstellungen, auch der Kopfzeile der htaccess an, ich denke, ich finde den Fehler nicht :-(

LG,
Wolfgang
Der an diesem Beitrag angefügte Anhang ist entweder nur im eingeloggten Zustand sichtbar oder die Berechtigung Deiner Benutzergruppe ist nicht ausreichend.
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.net
Beiträge: 17565
Dabei seit: 12 / 2003
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 28.09.2022 - 14:10 Uhr  ·  #5
Hi Wolfgang,

Zitat
M.M.n. wäre in der htaccess keine Anpassung erforderlich, da der Link zum Vorstellungsthread auch ohne "www" angegeben wurde. Ist das richtig?


theoretisch ja, aber um es für Suchmaschinen zu verbessern (Duplicate Content vermeiden) und auch eventuelle Anwendertippfehler auszugleichen würde ich die Anpassung trotzdem vornehmen.

In der Standard .htaccess findest Du diese Passage:
Code
  # -- uncomment next 6 lines to select your preferred forum domain (with or without www. - this example is without www)
  # RewriteCond %{HTTPS} =on
  # RewriteRule ^(.*)$ - [env=proto:https]
  # RewriteCond %{HTTPS} !=on
  # RewriteRule ^(.*)$ - [env=proto:http]
  # RewriteCond %{HTTP_HOST} ^www\. [NC]
  # RewriteRule ^(.*)$ %{ENV:proto}://yourdomain.net/$1 [L,R=301]


mach daraus in Deinem Fall
Code
  # -- uncomment next 6 lines to select your preferred forum domain (with or without www. - this example is without www)
  RewriteCond %{HTTPS} =on
  RewriteRule ^(.*)$ - [env=proto:https]
  RewriteCond %{HTTPS} !=on
  RewriteRule ^(.*)$ - [env=proto:http]
  RewriteCond %{HTTP_HOST} ^www\. [NC]
  RewriteRule ^(.*)$ %{ENV:proto}://musikzirkus.eu/$1 [L,R=301]


sollte es dann schon gewesen sein.


Beim Link kann ich, wenn der Link stimmt, mir aber trotzdem nur ein Berechtigungsphänomen erklären.

Was steht denn als Link da, wenn Du nur mit der Maus drüberfährst? Ist da in der Statusleiste auch der komplette Link zu sehen? Eventuell wird der Parameter escaped weil die Eintragung in die DB gesichert erfolgt, würd mich bei nem Fragezeichen aber wundern. Kannst mir auch gerne mal Deinen Testaccount per PM schicken wo ich den Link mal selber anschauen kann der beim User ankommt.

Viele Grüße,
Chris
badMoon
Benutzer
Avatar
Geschlecht:
Herkunft: Nettetal / NRW
Alter: 68
Homepage: musikzirkus.eu
Beiträge: 209
Dabei seit: 02 / 2013
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 28.09.2022 - 14:39 Uhr  ·  #6
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.net
Beiträge: 17565
Dabei seit: 12 / 2003
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 28.09.2022 - 15:09 Uhr  ·  #7
Hallo Wolfgang,

sehr gerne!

Du hattest nur die Rauten weggemacht, in der letzten Zeile gabs aber auch noch eine Änderung. :)
Da Du mir die Zugangsdaten geschickt hast auch für FTP und Co habe ich Dir das mit dem www aber mal schnell erledigt, das funktioniert jetzt also schon mal alles. ;)

Hast Du allerdings neben dem Admin Account noch den Zugang zu Deinem Testuser für mich, bei dem der Fehler auftritt und wo diese Willkommensnachricht liegt? Würde den Fehler gerne mal direkt da, wo er passiert, reproduzieren. Ansonsten kann ich auch gerne selbst einen (normalen) Testaccount anlegen, falls Du nicht schon einen hast.

Viele Grüße,
Chris
cback
Admin
Avatar
Geschlecht:
Herkunft: Saarland
Alter: 36
Homepage: cback.net
Beiträge: 17565
Dabei seit: 12 / 2003
Betreff:

Re: CBACK Welcome Post Konfiguration

 · 
Gepostet: 28.09.2022 - 15:42 Uhr  ·  #8
Moin Wolfgang,

danke für das Nachsenden vom Testaccount. Das war auch gut, weil auf die Ursache wäre ich nicht gekommen. :)

Nach Deiner Beschreibung hin hatte ich ja den Link von dem Begrüßungsthema in Verdacht, was Du aber meintest war die Meldung die bei einem Neuling kommt, wenn er sich erstmalig im Forum einloggt. Das Plugin öffnet hier ja ein automatisches Begrüßungstopic und zeigt dort in der Box einen Link zu eben diesem TOPIC(!) an.


In diesem Begrüßungstopic steht dann zwar Dein Link drin ABER das Topic selbst, das erstellt wird, lässt Du ja in einem ganz anderen Forum erstellen.

Nämlich im Forum "Wird in 30 Tagen gelöscht" mit der ID 47.

In diesem Forum hatte die Gruppe "Newbies" nur "darf Forum sehen" Befugnis, nicht aber "Themen lesen".

Habe die Berechtigung nun gesetzt und schon klappt der Link von der Infobox und der im Thema selbst in das ANDERE Forum mit Deiner ID 18 natürlich auch, das war ja schon korrekt gesetzt alles. ;)

LG,
Chris
Gewählte Zitate für Mehrfachzitierung:   0

Registrierte in diesem Topic

Aktuell kein registrierter in diesem Bereich

Die Statistik zeigt, wer in den letzten 5 Minuten online war. Erneuerung alle 90 Sekunden.